Andreas Unkelbach
Werbung


Samstag, 13. Juni 2015
18:52 Uhr

Excel: WVERWEIS Funktion oder Jahresdaten umgruppieren für Mehrjahresvergleich

Ausgangslage:
Für einen Dreijahresbericht wurden bisher Jahresdaten für drei Jahre dargestellt und jedes Jahr aufs neue für ein Jahr aktualisiert. Hierbei wurden die "Altdaten" einfach ausgeblendet bzw. der Druckbereich in Excel passend gemacht.

So wurden die Ergebnisse auf Ebene Fachbereich, Lehreinheit und als kleinste Ebene Studiengang wie folgt dargestellt:

Darstellung Ergebnis Fachbereich, Lehreinheit, Studiengang aufsteigend

Für die Dreijahressicht (Berichtstermin ist Anfang 2016) sollen die Jahre 2013 bis 2015 dargestellt werden. Hierzu sind in den folgenden Spalten die aktuellen Jahresdaten einzutragen und die Vorjahresspalten auszublenden beziehungsweise durch Gruppierung nicht darzustellen. Entsprechend wären hier nur die Spalten A sowie D bis F für den Bericht dargestellt worden. Die Jahresdaten für 2016 sind dann in der Spalte G künftig zu ergänzen.

Da das Berichtswesen mehr in eine kaufmännische Sicht übergeführt werden soll, wurde der Wunsch geäußert alle Berichtsdaten nun absteigend darzustellen, so dass Aktuelles Jahr, Vorjahr und VorVorjahr dargestellt werden sollen (2015, 2014, 2013). Eine solche Darstellung entspricht der umgekehrten Reihenfolge und würde ein Aktualisieren der Daten erschweren, sofern man in der entsprechenden Tabelle auch die Vorjahresdaten weitehrin erhalten lassen möchte.

Damit die Datenhaltung weiterhin erfolgen kann, wurde hier die Tabelle ein wenig abgeändert und um die Funktion WVERWEIS ergänzt.

Verweisfunktionen in Excel

Grundsätzlich gibt es in Excel drei Verweisfunktionen, wobei die SVERWEIS Funktion vermutlich die bekannteste ist.

1. VERWEIS Funktion
Dabei ist die Formel/Funktion VERWEIS die Grundfunktion und ist am dynamischsten in der Anwendung. Ein Anwendungsbeispiel wurde im Artikel "Prüfung inwieweit ein Wert, bspw. eine Kostenstelle, innerhalb eines Intrevalls (Gruppe) liegt in Excel" schon einmal dargestellt.

2. SVERWEIS Funktion
Die SVERWEIS Funktion dürfte eine der bekannteren Formeln im Controlling sein.
Dabei ist sie wie folgt aufgebaut.

=SVERWEIS(Suchkriterum;Matrix;Spaltenindex;Bereich_Verweis)

Anhand eines Suchkriteriums wird eine Matrix (Suchbereich) durchsucht und die entsprechende Spalte ausgegeben, die mit der ersten Spalte übereinstimmt. Ferner wird über Bereich_Verweis festgelegt ob eine exakte übereinstimmung (FALSCH) oder ungefähre Übereinstimmung (WAHR) gewünscht ist.

3. WVERWEIS Funktion

Diese Funktion arbeitet vergleichbar zur SVERWEIS Funktion gibt aber nicht Spalten sondern gibt das Ergebnis aus einen Zeilenindex heraus.

Dabei ist sie wie folgt aufgebaut.

=WVERWEIS(Suchkriterum;Matrix;Zeilenindex;Bereich_Verweis)

Als Eselsbrücke könnte man sich merken, dass die SVERWEIS Funktion senkrecht nach der ersten Spalte die Daten durchsucht, wohingegen die WVERWEIS Funktion waagrecht in der ersten Zeile nach einer Übereinstimmung sucht und die folgenden Daten dann anhand des übergegeben Index ausgibt.

Eine ausführliche Beschreibung der unterschiedlichen Verweis-Funktionen ist im Artikel "Grundlagen in Excel Verweisfunktionen SVERWEIS WVERWEIS und VERWEIS" zu finden. Hier ist auch auf eine Alternative mit INDEX und VERGLEICH verwiesen worden.
 

Anwendungsbeispiel WVERWEIS Funktion (Jahresdaten umsortieren)


Was bedeutet dieses nun aber für unsere Ursprungstabelle?
Hier haben wir die Tabelle um 4 Spalten (im Beispiel die Spalten B bis E) erweitert und die Spalten F bis J über die Symbolleiste (Ribbon) Formeln über die Funktion Namen definieren die Bezeichnung "Jahresdaten_Studis" zugewiesen. Ferner sind in der Spalte E die einzelnen Zeilen  der Datentabelle (Jahresdaten_Studis) durchnummeriert worden.

Grundlagendaten Namen definieren Jahresdaten_Studis
Der definierte Name mit Bezug auf F1 bis J10 kann in den folgenden Jahren immer wieder erweitert werden, soll aber für unser Beispiel die Matrix der einzelnen Jahre sein und anhand der WVERWEIS Funktion für die Darstellung der letzten drei Jahre in den Spalten B bis D genutzt werden.

Beispiel WVERWEIS

Die Formel in der Zelle B2 lautet wie folgt:

=WVERWEIS(B$1;Jahresdaten_Studis;$E2;falsch)


Hierdurch wird fix die Zeile 1 als Suchvektor über die Matrix "Jahresdaten_Studies" genutzt um anhand des Zeilenindex (in der Spalte E) die genaue Übereinstimmung (falsch) auszugeben. Hierbei wird als Suchkriterium das entsprechende darzustellende Geschäftsjahr genutzt. Durch Setzung des Druckbereichs auf =$A$1:$D$10 werden dann auch tatsächlich nur die relevanten Daten mit ausgedruckt aber es ist weiterhin möglich die aktuellen Daten als "neue" Spalte einzufügen.

Durch die  mit $ markierten absoluten Bezüge (Zeile $1, Jahresdaten_Studies; Spalte $E) kann die Formel auch in den anderen Zellen kopiert werden und per Inhalte einfügen Formel entsprechend automatisch von Excel angepasst werden.

Im konkreten Beispiel sehen die Formeln wie folgt aus:

Formelansicht WVERWEIS
Jede Zelle verweist dabei auf das für sie relevante Jahr in der Zeile 1 und durchsucht die Jahresdaten_Studis. Ferner soll als Ergebnis die in der Spalte E angegebene Ergebniszeile ausgegeben werden.

Mit aktivierter Umbruchvorschau kann das Ergebnis der Formel dargestellt werden.

Ergebnis WVERWEIS absteigende Jahresdarstellung der Studierendendaten

Auf diese Weise werden die Studierendendaten in absteigender Jahresfolge dargestellt und außerhalb des Druckbereichs können aktuelle Daten erfasst werden. Hierdurch sind auch komplexere Entscheidungen wie Wechsel der Jahresdarstellung unter Beibehaltung der Grunddaten mit relativ wenig Aufwand umzusetzen.



Hinweis: Aktuelle Buchempfehlungen besonders SAP Fachbücher sind unter Buchempfehlungen inklusive ausführlicher Rezenssionen und Bestellmöglichkeit zu finden.
Espresso Tutorial - die digitale SAP Bibliothek

Tags: Excel

Keine Kommentare - - Office

Artikel datenschutzfreundlich teilen

🌎 Facebook 🌎 Twitter 🌎 Google
Diesen und weitere Texte von finden Sie auf http://www.andreas-unkelbach.de


Keine Kommentare

Kommentieren?


Beim Versenden eines Kommentars wird mir ihre IP mitgeteilt. Diese wird jedoch nicht dauerhaft gespeichert (siehe auch XII. Fremde Nutzung / Kommentarfunktion in der Datenschutzerklärung).

Eine Rückmeldung ist entweder per Schnellkommentar oder (weiter unten) als normalen Kommentar möglich. Eine persönliche Rückmeldung (gerne auch Fragen zum Thema) würde mich sehr freuen.

Schnellkommentar (Kurzes Feedback, ausführliche Kommentare bitte unten als normaler Kommentar)

Name (sofern kein Name angegeben wird erscheint Anonym):


Normaler Kommentar

Name:

E-Mail (wird nicht veröffentlicht):

Homepage:

Kommentar:


Hinauf




Werbung



Logo Andreas-Unkelbach.de
© 2004 - 2018 Andreas Unkelbach
Gießener Straße 75,35396 Gießen,Germany
andreas.unkelbach@posteo.de
Andreas Unkelbach

Stichwortverzeichnis
(Tagcloud)


Aktuelle Infos (Abo)

Facebook Twitter Google+

»Schnelleinstieg ins SAP Controlling (CO)« und »Berichtswesen im SAP ® ERP Controlling«
Privates

Kaffeekasse 📖 Wunschliste