Andreas Unkelbach
Werbung


Dienstag, 14. Februar 2017
18:42 Uhr

Leerzeilen bei Zeilenbeschriftungen in Excel Pivottabellen auffüllen

Im Rahmen eines Finanzberichtswesen werden verschiedene Projekte nach ihren verschiedenen Merkmalen ausgewertet und sollen je Fachbereich nach Kostenstelle und Finanzierungszweck (Finuse) einzelne Projekte mit ihren jeweiligen Salden aus mehreren Datenquellen zusammengestellt werden. Basis für die Auswertung sind in den Artikeln "»Rechercheberichte de lux« im Modul PSM FM Haushaltsmanagement" beziehungsweise "Drittmittelstatistik nach LOMZ über Recherchebericht und SAP Query" ausgewertet werden.

Was ist ein Finanzierungszweck?
Die Rolle des Feldes Finanzierungszweck im SAP Modul PSM ist in den beiden Artikeln "PSM-FM Grundlagen Finanzierungszweck im Haushaltsmanagement bei Recherchebericht und Selektion", "Gruppierung von Finanzierungszwecken bei Drittmittelprojekten per Zusatzfeldcoding mit IF oder CASE" beschrieben.


Die entsprechende Grundtabelle (Datengrundlage) sieht dabei im Ausschnitt und sehr vereinfacht wie folgt aus:

Grundtabelle nach Fachbereich Auftrag und Finanzierungszweck
 

Pivottabelle klassisches Layout anlegen

Der naheliegende Gedanke diese Tabelle mit einer Pivottabelle (siehe auch Artikel "Pivottabellen ab Excel 2010 dynamischer filtern mit Datenschnitten am Beispiel Hochschulfinanzstatistik" ) anzulegen.

Im Ergebnis sieht eine eingefügte PivotTabelle dann wie folgt aus:

Pivot Tabelle nach Fachbereich Kostenstelle Finanzierungszweck und Auftrag

Die Darstellung der Werte Fachbereich, Kostenstelle, Finuse und Auftrag auf einer Ebene ist durch die Pivottabellen-Optionen (rechte Maustaste auf die Pivottabelle) und hier der Reiter Anzeige und die Option Klassisches PivotTabellen-Layout festgelegt worden.

Pivot Tabellen Optionen

Ferner sind für die einzelnen Zellen keine Teilergebnisse festgelegt worden.

Geplant ist nun eigentlich für die einzelnen Fachbereiche die Ergebnisse je Kostenstelle zu kopieren und als Tabelle zur Verfügung zu stellen.

Hier gab es dann jedoch die Rückmeldung, dass die leeren Zellen unterhalb der mehrfach vorkommenden Kostenstelle aufgefüllt werden sollten. Leider ist mir keine Option in den Pivottabellen bekannt, dass sich hier die Gruppierung wiederholen lässt. Daher hilft hier eine kleine Formellösung weiter.

Vor der Pivottabelle wurden daher vier weitere Spalten eingefügt und dabei mit einer Formel die Fachbereich, Kostenstelle und Finuse (Finanzierungszweck) aufgefüllt.

Zellenbeschriftungen per Wenn Funktion automatisch auffüllen

Die automatische Auffüllen der leeren Zellenbeschriftungsfelder ist über eine WENN Funktion gelöst:

Zellenbeschriftungen per Wenn Funktion erweitern

Die Formel prüft ob die Pivottabellenzelle einen Wert hat (im Beispiel F3 ungleich leer sprich "") um dann den entsprechenden Eintrag einzfügen, andernfalls wird der Wert eine Zelle oberhalb dieser Formel eingetragen. Da die Formel nach unten ausgefüllt wird, wird dann tatsächlich immer der entsprehcende Wert ergänzt so dass hier die Zellenbeschriftungen ebenfalls nach unten ausgefüllt wird.

Die Formeln sehen dabei wie folgt aus:

Wenn Funktion um Zellenbeschriftungen darzustellen

in Zelle  A3 wird dabei auf das Feld D3 in der Pivottabelle Bezug genommen und durch die Formel =WENN(d3<>"";d3;a2) hier würde auf jeden Fall ein Wert vorhanden sein, aber shcon in Zelle A4 wird durch die Formel =WENN(d4<>"";d4;A3) der Wert aus A3 ausgewiesen, wenn hier kein Wert in der Pivottabelle steht.

Hierbei sind dann tatsächlich alle Kostenstellen und FInanzierungszwecke ergänzt und die Tabelle ist etwas besser lesbar.. Eleganter kann dieses aber mit einer bedingten Formatierung erfolgen.

Bedingte Formatierung identischer Werte

Durch die Regel "Werte formatieren, für die diese Formel wahr ist" wird geschaut, ob der Eintrag mit der Zelle drüber identisch ist.

Hier kann die Schriftfarbe in einen Grauton dargestellt werden, so dass sich wiederholende Werte entsprechend absetzen, wie am Beispiel des FB 03 ersichtlich ist.

Darstellung mit durchgehender Zellenbeschriftung

Hier zeigt sich erneut wie sinnvoll die Verwendung der bedingten Formatierung zum schnellen Erfassen von Daten genutzt werden kann.

Weitere Beispiele für die Anwendung von bedingten Formatierungen können unter "Excel: bedingte Formatierung mit Pfeilen (Darstellung Tendenzen bei Veränderungen)" oder auch im Artikel "Leistungsmengen im Grundbudget je Fächergruppe (Cluster) im Vergleich oder bedingte Formatierung für Minimalwerte und Maximalwerte" betrachtet werden.

Insgesamt ist diese Formellösung eine echte Erleichterung im Vergleich des manuellen Auffüllen der leeren Tabellenzellen.
 

Hinweis: Aktuelle Buchempfehlungen besonders SAP Fachbücher sind unter Buchempfehlungen inklusive ausführlicher Rezenssionen und Bestellmöglichkeit zu finden.
Espresso Tutorial - die digitale SAP Bibliothek

Diesen und weitere Texte von finden Sie auf http://www.andreas-unkelbach.de


Keine Kommentare

Kommentieren?


Beim Versenden eines Kommentars wird mir ihre IP mitgeteilt. Diese wird jedoch nicht dauerhaft gespeichert (siehe auch XII. Fremde Nutzung / Kommentarfunktion in der Datenschutzerklärung).

Eine Rückmeldung ist entweder per Schnellkommentar oder (weiter unten) als normalen Kommentar möglich. Eine persönliche Rückmeldung (gerne auch Fragen zum Thema) würde mich sehr freuen.

Schnellkommentar (Kurzes Feedback, ausführliche Kommentare bitte unten als normaler Kommentar)

Name (sofern kein Name angegeben wird erscheint Anonym):


Normaler Kommentar

Name:

E-Mail (wird nicht veröffentlicht):

Homepage:

Kommentar:


Hinauf




Werbung



© 2004 - 2017 Andreas Unkelbach
Gießener Straße 75,35396 Gießen,Germany
andreas.unkelbach@posteo.de
Andreas Unkelbach

Stichwortverzeichnis
(Tagcloud)


Aktuelle Infos (Abo)

Facebook Twitter Google+

Schnelleinstieg ins SAP Controlling (CO) von Martin Munzel & Andreas Unkelbach
Privates

Kaffeekasse 📖 Wunschliste